# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"TSH(?:\n|.)+?(?=\nTSH|\nEXT|\nTSV;4)"
test_str = ("EXH;2;20180514103023+00;\n"
"TSH;FI__REPLACEMGA_LOS_92_12345;1;1;HOUR;kWh;24;201805120000+00;201805130000+00;LOS_92_12345;;;;;;LOS_92_12345;;;\n"
"TSV;1;201805120000+00;0.000000;Z01;\n"
"TSV;2;201805120100+00;0.000000;Z01;\n"
"TSV;3;201805120200+00;0.000000;Z01;\n"
"TSH;FI__REPLACEMGA_LOS_93_12345;1;1;HOUR;kWh;24;201805120000+00;201805130000+00;LOS_93_12345;;;;;;LOS_93_12345;;;\n"
"TSV;1;201805120000+00;0.000000;Z01;\n"
"TSV;2;201805120100+00;0.000000;Z01;\n"
"TSV;3;201805120200+00;0.000000;Z01;\n"
"TSV;4;201805120300+00;0.000000;Z01;\n"
"TSH;FI__REPLACEMGA_LOS_96_12345;1;1;HOUR;kWh;24;201805120000+00;201805130000+00;LOS_96_12345;;;;;;LOS_96_12345;;;\n"
"TSV;1;201805120000+00;0.000000;Z01;\n"
"TSV;2;201805120100+00;0.000000;Z01;\n"
"TSV;3;201805120200+00;0.000000;Z01;\n"
"TSV;4;201805120300+00;0.000000;Z01;\n"
"TSH;FI__REPLACEMGA_LOS_97_12345;1;1;HOUR;kWh;24;201805120000+00;201805130000+00;LOS_97_12345;;;;;;LOS_97_12345;;;\n"
"TSV;1;201805120000+00;0.000000;Z01;\n"
"TSV;2;201805120100+00;0.000000;Z01;\n"
"TSV;3;201805120200+00;0.000000;Z01;\n"
"TSV;4;201805120300+00;0.000000;Z01;\n"
"EXT;")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.