$re = '/ferr([a][r][i]|[e][t]|[y])/m';
$str = 'ferrari
ferret
ferry';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);