$re = '/^[a-zA-Z-_]+_[0-9]+$/';
$str = 'voglia-di_cazzi-e-di-piscio_9999';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);