re = /^(19|20)\d\d[-](0[1-9]|1[012])[-](0[1-9]|[12][0-9]|3[01])$/
str = '2021-09/09'
# Print the match result
str.match(re) do |match|
puts match.to_s
end