$re = '/\$[a-zA-Z_]\w*(\[[^\]]+\])?/m';
$str = '$_GET["something"]
$a
$6
$_ab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);