package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[^\\d.A-Za-z @$#.]`)
var str = `@f$%#$#$#....- fdsfdsf sdfsdfsd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}