package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\+?\d{1,3})\s\d{10}$`)
var str = `+1297899859038`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}