package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\s\S]*?)(_swft-)`)
var str = `5152287-001_17SI1039.01_BASE_swft-105173.xml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}