#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^-?(0|[1-9]\d*)(\.\d+){1,20}?$"
Local $sString = "3" & @CRLF & _
"10000.76" & @CRLF & _
"999" & @CRLF & _
"-3" & @CRLF & _
"0" & @CRLF & _
"0.0" & @CRLF & _
"1.0" & @CRLF & _
"0.1" & @CRLF & _
".01" & @CRLF & _
"-0.0000000000000000000000000000000001" & @CRLF & _
"2e3" & @CRLF & _
"-2e3" & @CRLF & _
"2e-3" & @CRLF & _
"-2e-3" & @CRLF & _
"1.0e0" & @CRLF & _
"0.1e1" & @CRLF & _
".01e-1" & @CRLF & _
"-9.1e3" & @CRLF & _
"-9.1e-3" & @CRLF & _
"9E5" & @CRLF & _
"0e-11" & @CRLF & _
"0xff" & @CRLF & _
"0XFF" & @CRLF & _
"0x0" & @CRLF & _
"0xfe3" & @CRLF & _
"-0" & @CRLF & _
"-0.0" & @CRLF & _
"-0.0000000000000000000000000000000000" & @CRLF & _
"-.0" & @CRLF & _
"-.0000000000000000000000000000000000" & @CRLF & _
"1xff" & @CRLF & _
"0x" & @CRLF & _
"0x0fg3" & @CRLF & _
"0xf4." & @CRLF & _
".0xf" & @CRLF & _
"0xfe-3" & @CRLF & _
"-0xff" & @CRLF & _
"0.0xff" & @CRLF & _
"0xff.1" & @CRLF & _
"e89" & @CRLF & _
".e3" & @CRLF & _
"001" & @CRLF & _
"-00.2" & @CRLF & _
"3." & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
" -1" & @CRLF & _
"--1" & @CRLF & _
"-.1" & @CRLF & _
"2..3" & @CRLF & _
"2-" & @CRLF & _
"2...3" & @CRLF & _
"2.4.3" & @CRLF & _
"5-6-7" & @CRLF & _
".-1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")