import re
regex = re.compile(r"(?<=\bimport)(\s*(?:[a-z0-9A-Z]+(\s)+)*)((([a-zA-Z0-9]+\.)+)[a-zA-Z0-9]*\*?);")
test_str = ("/*\n"
"* Copyright 2009 Brian Pellin.\n"
"*\n"
"* This file is part of KeePassDroid.\n"
"*\n"
"* KeePassDroid is free software: you can redistribute it and/or modify\n"
"* it under the terms of the GNU General Public License as published by\n"
"* the Free Software Foundation, either version 2 of the License, or\n"
"* (at your option) any later version.\n"
"*\n"
"* KeePassDroid is distributed in the hope that it will be useful,\n"
"* but WITHOUT ANY WARRANTY; without even the implied warranty of\n"
"* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the\n"
"* GNU General Public License for more details.\n"
"*\n"
"* You should have received a copy of the GNU General Public License\n"
"* along with KeePassDroid. If not, see <http://www.gnu.org/licenses/>.\n"
"*\n"
"*/\n"
"package com.keepassdroid.tests.crypto;\n\n"
"import \n"
"static \n"
"test \n"
"test2 \n"
"org.junit.Assert.assertArrayEquals.*;\n\n"
"import \n"
"java.io.IOException;\n"
"import java.util.Random;\n\n"
"import junit.framework.TestCase;\n\n"
"import com.keepassdroid.crypto.finalkey.AndroidFinalKey;\n"
"import com.keepassdroid.crypto.finalkey.NativeFinalKey;\n\n"
"public class FinalKeyTest extends TestCase {\n"
" private Random mRand;\n"
" \n"
" @Override\n"
" protected void setUp() throws Exception {\n"
" super.setUp();\n"
" \n"
" mRand = new Random();\n"
" }\n"
" \n"
" public void testNativeAndroid() throws IOException {\n"
" // Test both an old and an even number to test my flip variable\n"
" testNativeFinalKey(5);\n"
" testNativeFinalKey(6);\n"
" }\n"
" \n"
" private void testNativeFinalKey(int rounds) throws IOException {\n"
" byte[] seed = new byte[32];\n"
" byte[] key = new byte[32];\n"
" byte[] nativeKey;\n"
" byte[] androidKey;\n"
" \n"
" mRand.nextBytes(seed);\n"
" mRand.nextBytes(key);\n"
" \n"
" AndroidFinalKey aKey = new AndroidFinalKey();\n"
" androidKey = aKey.transformMasterKey(seed, key, rounds);\n"
" \n"
" NativeFinalKey nKey = new NativeFinalKey();\n"
" nativeKey = nKey.transformMasterKey(seed, key, rounds);\n"
" \n"
" assertArrayEquals(\"Does not match\", androidKey, nativeKey);\n"
" \n"
" }\n"
"}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")