$re = '/[\.\,\;\?\!\s]+\'/';
$str = 'I don\'t use \'three\' or txo d\'6rt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);