using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:2[0-3]|[01]?[0-9]):[0-5][0-9]:[0-5][0-9]$";
string input = @"56:02
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}