$re = '/(?:^\||\G)\|?(\d+)(?=\|)/m';
$str = '|98|34|2|{"flag":"CHART"}|4|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);