$re = '/(?<=^|\s)(?:(?<=^|[^car])[a-zа-я](?=$|[^car]))+(?=$|\s)/mi';
$str = 'hello my friend автомобиль car автомобиль hello car hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);