// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)").unwrap();
let string = "
Canada , Toronto
IP: 104.166.127.78
IPv6: 2605:e440:6::71
http://104.166.127.78/1000MB.test
http://[2605:e440:6::71]/1000MB.test
China , Hong Kong
IP: 91.149.237.213
IPv6: 2605:e440:15::2:7b
http://91.149.237.213/1000MB.test
http://[2605:e440:15::2:7b]/1000MB.test
Finland , Helsinki
IP: 91.149.255.106
IPv6: 2605:e440:7::63
http://91.149.255.106/1000MB.test
http://[2605:e440:7::63]/1000MB.test
France , Paris
IP: 185.143.222.48
IPv6: 2605:e440:9::3:20
http://185.143.222.48/1000MB.test
http://[2605:e440:9::3:20]/1000MB.test
Germany , Frankfurt
IP: 91.149.223.204
IPv6: 2605:e440:1::1:14a
http://91.149.223.204/1000MB.test
http://[2605:e440:1::1:14a]/1000MB.test
Italy , Palermo
IP: 194.87.47.32
IPv6: 2605:e440:12::2:16
http://194.87.47.32/1000MB.test
http://[2605:e440:12::2:16]/1000MB.test
Latvia , Riga
IP: 194.58.34.42
IPv6: 2605:e440:13::20
http://194.58.34.42/1000MB.test
http://[2605:e440:13::20]/1000MB.test
Netherlands , Amsterdam
IP: 91.149.241.62
IPv6: 2605:e440:2::2e
http://91.149.241.62/1000MB.test
http://[2605:e440:2::2e]/1000MB.test
Poland , Warsaw
IP: 91.149.253.58
IPv6: 2605:e440:4::2:1f
http://91.149.253.58/1000MB.test
http://[2605:e440:4::2:1f]/1000MB.test
Russia , Novosibirsk, TTK
IP: 193.38.50.142
IPv6: 2a00:b700:4::1:291
http://193.38.50.142/50MB.test
http://[2a00:b700:4::1:291]/50MB.test
Russia , Novosibirsk, Rostelecom
IP: 46.29.162.89
IPv6: 2a00:b700:4:0:6463:23ff:fe8e:7335
http://46.29.162.89/50MB.test
http://[2a00:b700:4:0:6463:23ff:fe8e:7335]/50MB.test
Russia , Kazan
IP: 176.32.32.133
IPv6: 2a00:b700:1::f7
http://176.32.32.133/50MB.test
http://[2a00:b700:1::f7]/50MB.test
Russia , Saint Petersburg
IP: 194.87.68.192
IPv6: 2a00:b700:5::5:33c
http://194.87.68.192/50MB.test
http://[2a00:b700:5::5:33c]/50MB.test
Russia , Moscow, Fiord
IP: 212.60.5.88
IPv6: 2a00:b700:3::5:3e4
http://212.60.5.88/50MB.test
http://[2a00:b700:3::5:3e4]/50MB.test
Russia , Moscow, DataLine
IP: 46.17.40.85
IPv6: 2a00:b700::d:75
http://46.17.40.85/50MB.test
http://[2a00:b700::d:75]/50MB.test
Spain , Madrid
IP: 91.149.242.38
IPv6: 2605:e440:3::2:18
http://91.149.242.38/1000MB.test
http://[2605:e440:3::2:18]/1000MB.test
USA , Dallas
IP: 209.209.112.37
IPv6: 2605:e440::5:5
http://209.209.112.37/50MB.test
http://[2605:e440::5:5]/50MB.test
USA , Los-Angeles
IP: 155.254.192.138
IPv6: 2605:e440:5::2:118
http://155.254.192.138/1000MB.test
http://[2605:e440:5::2:118]/1000MB.test
USA , Atlanta
IP: 134.195.96.22
IPv6: 2605:e440:14::3:d
http://134.195.96.22/1000MB.test
http://[2605:e440:14::3:d]/1000MB.test
Ukraine , Kiev
IP: 194.87.189.8
IPv6: 2605:e440:10::2:4
http://194.87.189.8/1000MB.test
http://[2605:e440:10::2:4]/1000MB.test
United Kingdom , London
IP: 91.149.202.91
IPv6: 2605:e440:8::2:1b
http://91.149.202.91/1000MB.test
http://[2605:e440:8::2:1b]/1000MB.test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}