$re = '/>([^<]+)[^[]+\[([^\]]+)]\[([^\]]+)]/m';
$str = '<a class="btn disabled btn--warning">Intermediate</a> [Creating a tools pipeline for Horizon Zero Dawn][hzd-engine-tools]<br>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);