re = /(.+?)(?=\sFrom)/
str = 'Vans model 10 . 390 From Random Data
Nike model 982 . Errant From Default Data
Timberland old school From Whatever'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end