package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:ab){3}`)
var str = `xyzab abab xhababab`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}