$re = '/(?!00)\d\d/';
$str = '01 = match
10 = match
99 = match
00 = no match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);