$re = '/^([-_ ʘa-zà-ù0-9]+)$/mi';
$str = 'giacomo
pedro
Kraut
Giò
ʘ_ʘ
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);