$re = '/^(?!(.)\1+$)[XO]{5}$/m';
$str = 'OXOXO
XXXXX
OXXXX
XXXXO
OOOOO
XOXOX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);