import re
regex = re.compile(r"(.*)\t(\d*\.\d*[^[:space:]+\t])")
test_str = ("Electrical Parameters \n"
"Re 3.70 Ohm electrical voice coil resistance at DC\n"
"Le 0.069 mH frequency independent part of voice coil inductance\n"
"L2 0.086 mH para-inductance of voice coil\n"
"R2 1.07 Ohm electrical resistance due to eddy current losses\n"
"Cmes 110.16 µF electrical capacitance representing moving mass\n"
"Lces 12.83 mH electrical inductance representing driver compliance\n"
"Res 42.92 Ohm resistance due to mechanical losses\n"
"fs 133.9 Hz driver resonance frequency \n"
" \n"
"Mechanical Parameters \n"
"(using laser) \n"
"Mms 1.212 g mechanical mass of driver diaphragm assembly including air load and voice coil\n"
"Mmd (Sd) 1.145 g mechanical mass of voice coil and diaphragm without air load \n"
"Rms 0.256 kg/s mechanical resistance of total-driver losses\n"
"Cms 1.166 mm/N mechanical compliance of driver suspension\n"
"Kms 0.86 N/mm mechanical stiffness of driver suspension\n"
"Bl 3.317 N/A force factor (Bl product)\n"
"Lambda s 0.114 suspension creep factor\n"
" \n"
"Loss factors \n"
"Qtp 0.316 total Q-factor considering all losses\n"
"Qms 3.976 mechanical Q-factor of driver in free air considering Rms only\n"
"Qes 0.343 electrical Q-factor of driver in free air considering Re only\n"
"Qts 0.315 total Q-factor considering Re and Rms only\n"
" \n"
"Other Parameters \n"
"Vas 0.3816 l equivalent air volume of suspension \n"
"n0 0.257 % reference efficiency (2 pi-radiation using Re) \n"
"Lm 86.30 dB characteristic sound pressure level (SPL at 1m for 1W @ Re)\n"
"Lnom 86.64 dB nominal sensitivity (SPL at 1m for 1W @ Zn)\n"
" \n"
"rmse Z 4.98 % root-mean-square fitting error of driver impedance Z(f)\n"
"rmse Hx 2.97 % root-mean-square fitting error of transfer function Hx (f)\n"
" \n"
"Series resistor 0.00 Ohm resistance of series resistor\n"
"Sd 15.21 cm² diaphragm area\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")