$re = '/\(*\w+\)*(\^)+\(*\w+\)*/i';
$str = '8^(8) 8^(8) 8^(8) (890)^(8)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);