package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`("(?:\\.|[^"\\])*")|([^\s]+)`)
var str = `console "any parameters" with "escaped \"quotes\"" without "optimizations"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}