import re
regex = re.compile(r"^'([^']*)'$")
test_str = "'text is single quoted'"
subst = "\\1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)