import re
regex = re.compile(r"""
(?=
({%.if
(?:
(?>
(?:
(?! {%.if | endif.%}) .
)+
)*
| (?1)
)*
endif.%})
)
(?1)
""", flags=re.VERBOSE | re.DOTALL | re.MULTILINE)
test_str = ("{% if something %}\n"
" DEEP\n"
" {% if something %}\n"
" DEEPER\n"
" {% endif %}\n\n"
"{% something totally different %}\n\n"
" {% if something %}\n"
" DEEPER\n"
" {% if something %}\n"
" DEEPEST\n"
" {% endif %}\n"
" DEEPER\n"
" {% endif %}\n"
" DEEP\n"
"{% endif %}\n\n"
"neue\n\n"
"{% if NODE %}\n"
" DEEP\n"
" {% if something %}\n"
" DEEPER\n"
" {% endif %}\n\n"
"{% something totally different %}\n\n"
" {% if something %}\n"
" DEEPER\n"
" {% if something %}\n"
" DEEPEST\n"
" {% endif %}\n"
" DEEPER\n"
" {% endif %}\n"
" DEEP\n"
"{% endif %}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")