package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)modules\\(.*?)\\controllers`)
var str = `test\modules\test\controllers`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}