package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(classId=|id=)([^&]*)`)
var str = `<a href="http://172.23.4.16/Workplace/Browse.jsp?eventTarget=WcmController&eventName=GetInfo&id={350B278C-DE7D-44DE-9B54-099672152476}&vsId=&classId={F14AC85A-4474-479A-9B4E-BCBA180B7975}&objectStoreName=Nice&majorVersion=&minorVersion=&versionStatus=&mimeType=&mode=&objectType=customobject&isPopup=true" target="_blank">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}