$re = '/Foo:(?<groupA>\w+)(?: \w+)* \g<groupA>-(?<groupB>\w+)/m';
$str = 'Foo:Bar Lorem ips rest sfsf um Bar-564875XC4 dolor sit amet
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);