const regex = new RegExp('^
(?P<interesting>.+?) # before
(?P<uid>\\b\\w{8}-(?:\\w{4}-){3}\\w{12}\\b) # uid
(?P<junk>.+) # garbage
$', 'gm')
const str = `00000 Gin-a19ea68e-64bf-4471-b4d1-44f6bd9c1708-62fa6ae2-599c-4ff1-8249-bf6411ce3be7-83930e63-2149-40f0-b6ff-0838596a9b89 Kin
00000 Gin-a19ea68e-64bf-4471-b4d1-44f6bd9c1708 Kin
test123 test 12345678-1234-1234-1234-123456789012 junk afterwards
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}