# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<entry>@(\w+)\{(\w+),(?<kvp>\W*([a-zA-Z]+) = \{(.+)\},)(?&kvp)*(\W*([a-zA-Z]+) = \{(.+)\})\W*\},?\s*)(?&entry)*"
test_str = ("@article{Gettys90,\n"
" author = {Jim Gettys and Phil Karlton and Scott McGregor},\n"
" abstract = {A technical overview of the X11 functionality. This is an update of the X10 TOG paper by Scheifler \\& Gettys.},\n"
" journal = {Software Practice and Experience},\n"
" volume = {20},\n"
" number = {S2},\n"
" title = {The {X} Window System, Version 11},\n"
" year = {1990}\n"
"},\n\n"
"@article{Gettys90,\n"
" author = {Jim Gettys and Phil Karlton and Scott McGregor},\n"
" abstract = {A technical overview of the X11 functionality. This is an update of the X10 TOG paper by Scheifler \\& Gettys.},\n"
" journal = {Software Practice and Experience},\n"
" volume = {20},\n"
" number = {S2},\n"
" title = {The {X} Window System, Version 11},\n"
" year = {1990}\n"
"},\n\n"
"@article{Gettys90,\n"
" author = {Jim Gettys and Phil Karlton and Scott McGregor},\n"
" abstract = {A technical overview of the X11 functionality. This is an update of the X10 TOG paper by Scheifler \\& Gettys.},\n"
" journal = {Software Practice and Experience},\n"
" volume = {20},\n"
" number = {S2},\n"
" title = {The {X} Window System, Version 11},\n"
" year = {1990}\n"
"}")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.