$re = '/(f?)(a?)(i?)(l?)(h?)(e?)(r?)(e?)/';
$str = 'failNow';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);