import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^config d(hcp|ns) ip(v4)? (<[^>]*>|(?:\\d+\\.){3}\\d+)( port| timeout|\\s*$)( <[^>]*>\\s*$| \\d+\\s*$|\\s*$)|config (router|interface) (id|bgp|name) (<[^>]*>\\s*$|<[^>]*> id <[^>]*>\\s*$|\\d+\\s*$|[a-z]+ id \\d+\\s*$|\\s*$)";
final String string = "config dhcp ip <dhcp-ipaddress> port <dhcp-port-number>\n"
+ "config dhcp ip <dhcp-ipaddress> timeout <time-out-value>\n"
+ "config dhcp ipv4 <dhcp-ipaddress>\n"
+ "config dns ip <dns-ipaddress> port <dns-port-number>\n"
+ "config dns ip <dns-ipaddress> timeout <time-out-value>\n"
+ "config router bgp <bgp-number>\n"
+ "config interface id <interface-id> \n"
+ "config interface name <interface-name> id <interface-id>\n\n"
+ "config dhcp ip 1.1.1.1 port 8080\n"
+ "config dhcp ip 1.1.1.2 timeout 120\n"
+ "config dhcp ip 1.1.1.1 timeout 120\n"
+ "config dhcp ip 1.1.1.2 port 8080\n"
+ "config dhcp ipv4 1.1.1.3\n"
+ "config interface id 12 \n"
+ "config interface name abc id 12\n"
+ "config interface id 13 \n"
+ "config interface name xyz id 13\n\n"
+ "config dhcp ip 1.1.1.1 port 8080\n"
+ "config dhcp ip 1.1.1.1 timeout 120\n"
+ "config dhcp ip 1.1.1.2 timeout 120\n"
+ "config dhcp ip 1.1.1.2 port 8080\n"
+ "config dhcp ipv4 1.1.1.3\n"
+ "config interface id 12 \n"
+ "config interface name abc id 12\n"
+ "config interface id 13 \n"
+ "config interface name xyz id 13";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}