$re = '/^(?=\w*[A-Za-z])\w*$/m';
$str = 'testabcd
23
23d
d234
d2 34
d234
d234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);