using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<next_open_tag>
[^<]*+
(?i: <++[^<?s][^<]*
| <++(?! \?php
| \?=
| script\s*language\s*=\s*([\'""]?)php\g{-1}\s*>
) [^<]*
)*+
(?i: <++(?: \?php
| \?=
| [^>]+
)
| \z
)
)
)
\A (?&next_open_tag) \K
|
[^'""`/#<?]*+
(?: '(?:[^'\\]+|\\.)*+' [^\'""`/#<?]*
| ""(?:[^""\\]+|\\.)*+"" [^\'""`/#<?]*
| `(?:[^`\\]+|\\.)*+` [^\'""`/#<?]*
| /(?![/*]) [^\'""`/#<?]* # stop for // or /*
| # if close tag ?>
\? (?: >(?&next_open_tag)[^\'""`/#<?]* | )
| < (?: # heredoc or nowdoc
<<[\ \t]*([\'""]?)
([a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*)
\g{-2}[\ \t]*[\r\n]
(?-s:.*+[\r\n])*?
\g{-1}[\r\n;]
[^\'""`/#<?]*
| (?i: /script\s*>)
(?&next_open_tag)
[^\'""`/#<?]*
| [^\'""`/#<?]*
)
)*+
\K
(?: (?://|\#)(?:[^\n?]+|\?(?!>))*+ # single line comment // и #
| /\*(?:[^*]+|\*(?!/))*+\*/ # multi line comment /* */
)?
";
string substitution = @"";
string input = @"<!-- *//* -->
<?php
$a = ""text */*""; // comment
$b = 'text *//*'; # comment
//*
if ($a) {
echo $b;
}
/*/
if ($bar) {
echo $foo;
}
// */
?>
<!-- *//* -->
<script language = ""php"" >
# comment ?> Text <?php $a = '/*'; // comment
$b = @`ls ./* -al`;
# */
</script>
<!-- *//* -->
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}