re = /(?!lorem[\s\S]*ipsum|ipsum[\s\S]lorem)^.*$/i
str = 'Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end