#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(.*\()"
Local $sString = "// API callback" & @CRLF & _
"google.search.Search.apiary2387({" & @CRLF & _
" "cursor": {" & @CRLF & _
" "currentPageIndex": 0," & @CRLF & _
" "estimatedResultCount": "4490"," & @CRLF & _
" "moreResultsUrl": "http://www.google.com/cse?oe=utf8&ie=utf8&source=uds&q=ssh&start=0&sort=&cx=013305635491195529773:0ufpuq-fpt0"," & @CRLF & _
" "resultCount": "4,490"," & @CRLF & _
" "searchResultTime": "0.22"," & @CRLF & _
" "pages": [" & @CRLF & _
" {" & @CRLF & _
" "label": 1," & @CRLF & _
" "start": "0"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "label": 2," & @CRLF & _
" "start": "1"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "label": 3," & @CRLF & _
" "start": "2"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "label": 4," & @CRLF & _
" "start": "3"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "label": 5," & @CRLF & _
" "start": "4"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "label": 6," & @CRLF & _
" "start": "5"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "label": 7," & @CRLF & _
" "start": "6"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "label": 8," & @CRLF & _
" "start": "7"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "label": 9," & @CRLF & _
" "start": "8"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "label": 10," & @CRLF & _
" "start": "9"" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" "context": {" & @CRLF & _
" "title": "Pastebin Active"," & @CRLF & _
" "total_results": "0"," & @CRLF & _
" "facets": []" & @CRLF & _
" }," & @CRLF & _
" "results": [" & @CRLF & _
" {" & @CRLF & _
" "GsearchResultClass": "GwebSearch"," & @CRLF & _
" "cacheUrl": "http://www.google.com/search?q=cache:PBL2A25kpZoJ:pastebin.com"," & @CRLF & _
" "clicktrackUrl": "https://www.google.com/url?q=http://pastebin.com/u/ssh&sa=U&ved=0ahUKEwiO4fjNpovMAhWBPxoKHYJXAS4QFggEMAA&client=internal-uds-cse&usg=AFQjCNHczEhDXdcUnRZhpArEeSiHfjwMJA"," & @CRLF & _
" "content": "BitBucket - Backup your code in the cloud! Host unlimited private projects, for free\n. SIGN UP takes 10 seconds, and it's free! Guest ..."," & @CRLF & _
" "contentNoFormatting": "BitBucket - Backup your code in the cloud! Host unlimited private projects, for free\n. SIGN UP takes 10 seconds, and it's free! Guest ..."," & @CRLF & _
" "formattedUrl": "pastebin.com/u/\u003cb\u003essh\u003c/b\u003e"," & @CRLF & _
" "title": "\u003cb\u003eSsh's\u003c/b\u003e Pastebin - Pastebin.com"," & @CRLF & _
" "titleNoFormatting": "Ssh's Pastebin - Pastebin.com"," & @CRLF & _
" "unescapedUrl": "http://pastebin.com/u/ssh"," & @CRLF & _
" "url": "http://pastebin.com/u/ssh"," & @CRLF & _
" "visibleUrl": "pastebin.com"," & @CRLF & _
" "richSnippet": {" & @CRLF & _
" "cseImage": {" & @CRLF & _
" "src": "http://pastebin.com/i/facebook.png"" & @CRLF & _
" }," & @CRLF & _
" "metatags": {" & @CRLF & _
" "fbAppId": "231493360234820"," & @CRLF & _
" "ogTitle": "Ssh's Pastebin - Pastebin.com"," & @CRLF & _
" "ogType": "article"," & @CRLF & _
" "ogUrl": "http://pastebin.com/u/ssh"," & @CRLF & _
" "ogImage": "http://pastebin.com/i/facebook.png"," & @CRLF & _
" "ogSiteName": "Pastebin"," & @CRLF & _
" "viewport": "width=device-width, maximum-scale=1.0, user-scalable=no"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
"}" & @CRLF & _
");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")