$re = '/(COT|MED)[ABCD]?-?[0-9]{1,4}(([JK]+[0-9]*)|(\ DDD)?)\b/m';
$str = 'MED-125
COTA-1224
MED4
COTB-892K777
MED-33 DDD
MED-12J44445
MED-234J5672
COT-11161K11111111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);