#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.?\d)\d*[.,]?\d*$"
Local $sString = "1" & @CRLF & _
"123" & @CRLF & _
"123." & @CRLF & _
"123.4" & @CRLF & _
"123.456" & @CRLF & _
".456" & @CRLF & _
"123," & @CRLF & _
"123,4" & @CRLF & _
"123,456" & @CRLF & _
",456" & @CRLF & _
"" & @CRLF & _
"0.,1" & @CRLF & _
"0a,1" & @CRLF & _
"0..1" & @CRLF & _
"1.1.2" & @CRLF & _
"100,000.99" & @CRLF & _
"100.000,99" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")