import re
regex = re.compile(r"((([a-z]\[[^\]]+\])(.{1}))?(\s*\=\>\s*)((([a-z]\[[^\]]+\])|([a-z].))(.{1})([A-Z]?)))?(\s*\/\/.*)?")
test_str = ("// Алгоритм умножения. Формат ленты: [*]1111#111=*\n"
"// Множество: Q; Начальное значение: q[0]; Конечное значение: q*;\n"
"// Символ пустой ячейки: _; Символ перехода влево: L; Символ перехода вправо: R\n"
"q[0]1 => q[0]1R //2312312323\n"
"q[0]# => q[1]#R\n"
"q[0]* => q[0]*R\n"
"q[1]1 => q[2]aR\n"
"q[2]1 => q[2]1L\n"
"q[2]# => q[3]#L\n"
"q[2]= => q[2]=L\n"
"q[2]a => q[2]aL\n"
"q[3]1 => q[4]aR\n"
"q[3]a => q[3]aL\n"
"q[3]* => q[6]*R\n"
"q[4]1 => q[4]1R\n"
"q[4]# => q[4]#R\n"
"q[4]= => q[4]=R\n"
"q[4]a => q[4]aR\n"
"q[4]* => q[5]1R\n"
"q[5]_ => q[2]*L\n"
"q[6]# => q[7]#R\n"
"q[6]a => q[6]1R\n"
"q[7]1 => q[2]aR\n"
"q[7]= => q[8]=L\n"
"q[7]a => q[7]aR\n"
"q[8]# => q*#\n"
"q[8]a => q[8]1L")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")