$re = '/^\d+(\,\d{3})*(\.\d{1,4})?$/m';
$str = '100
1.0
1.001
1.000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);