import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<DIV\\s*class=\"[^\"]*lesson.*><[aA][^>]*class=large-text[^>]*href\\s*=[\\*\"|'](.*?)[\\*\"|']>((.|\\n)*?)<\\/[aA]>[.|\\n]*<\\/DIV|div>";
final String string = "<form action=\"#\" id=\"ModalFormB\" method=\"POST\">\n"
+ " <table>\n"
+ " <colgroup>\n"
+ " <col class=\"nome_riga\">\n"
+ " <col class=\"desc_riga\">\n"
+ " <col class=\"normale\" span=\"<?=$results['colonne']-3?>\">\n"
+ " <col class=\"ultima\">\n"
+ " </colgroup>\n"
+ " <tr class=\"nascosta\">\n"
+ " <th class=\"nome_riga\"></th>\n"
+ " <th class=\"desc_riga\"></th>\n"
+ " <th class=\"normale\" colspan=\"<?=$results['colonne']-3?>\"></th>\n"
+ " <th class=\"ultima\"></th>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td colspan=\"<?=$results['colonne']?>\" class=\"verde\">B. Impianti di generazione di energia\n"
+ " (termica, elettrica, cogenerazione, ...)<br> Aggiungere nuove\n"
+ " colonne in caso l'impianto sia dotato di più di 4 generatori.\n"
+ " <input type=\"hidden\" name=\"IdQuestionario\" value=\"<?=$IdQuestionario?>\" />\n"
+ " </td>\n"
+ " </tr>\n\n"
+ " <?=$results['Intestazione']?>\n\n"
+ " <tr class=\"required\">\n"
+ " <td class=\"capolinea\">B0.</td>\n"
+ " <td class=\"grassetto\">Funzione</td>\n"
+ " <?=$results['Funzione']?>\n"
+ " <td> </td>\n"
+ " </tr>\n\n"
+ " <tr class=\"required\">\n"
+ " <td class=\"capolinea\">B1.</td>\n"
+ " <td class=\"grassetto\">Potenza termica nominale</td>\n"
+ " <?=$results['PotenzaTermica']?>\n"
+ " <td class=\"corsivo\">Indicare la potenza termica nominale di ogni\n"
+ " generatore [kW]</td>\n"
+ " </tr>\n\n"
+ " <tr class=\"required\">\n"
+ " <td class=\"capolinea\">B2.</td>\n"
+ " <td class=\"grassetto\">Potenza elettrica nominale</td>\n"
+ " <?=$results['PotenzaElettrica']?>\n"
+ " <td class=\"corsivo\">Indicare la potenza elettrica nominale di ogni\n"
+ " generatore [kW]</td>\n"
+ " </tr>\n\n"
+ " <tr class=\"required\">\n"
+ " <td class=\"capolinea\">B3.</td>\n"
+ " <td class=\"grassetto\">Fonti energetiche utilizzate</td>\n"
+ " <?=$results['Fonti']?>\n"
+ " <td class=\"corsivo\">Indicare per ogni unità di generazione la/le\n"
+ " fonte/fonti utilizzata/e per produzione di energia termica,\n"
+ " rinnovabile o non rinnovabile (in caso di recuperi da processi\n"
+ " industriali, specificare la fonte utilizzata nel processo). Nel caso\n"
+ " di più fonti separare le singole fonti utilizzando il ; (punto e\n"
+ " virgola).\n"
+ " <br>\n"
+ " <b>Indicare una delle seguenti voci: pellet di legno;\n"
+ " cippato di legno; vinacce; gusci; sansa; altra biomassa legnosa;\n"
+ " olio vegetale grezzo; altri bioliquidi; biogas; rifiuti\n"
+ " industriali; rifiuti urbani; energia solare termica; energia\n"
+ " geotermica; carbone; gas naturale; gasolio; altri prodotti\n"
+ " petroliferi; pompa di calore idrotermica; pompa di calore\n"
+ " aerotermica; pompa di calore geotermica. </b></td>\n"
+ " </tr>\n\n"
+ " <tr class=\"required\">\n"
+ " <td class=\"capolinea\" rowspan=\"2\">B4.</td>\n"
+ " <td class=\"grassetto\" rowspan=\"2\">Rendimento di conversione medio\n"
+ " dell'impianto</td>\n"
+ " <?=$results['RendimentoImpianto']?>\n"
+ " <td> </td>\n"
+ " </tr>\n"
+ " <tr class=\"required\">\n"
+ " <?=$results['RendImpCostr']?>\n"
+ " <td>specificare se: dichiarato dal costruttore o dato medio ricavato\n"
+ " in esercizio</td>\n"
+ " </tr>\n\n"
+ " <tr class=\"cogenerazione\">\n"
+ " <td class=\"capolinea\" rowspan=\"2\">B5.</td>\n"
+ " <td class=\"grassetto\" rowspan=\"2\">Rendiemento di conversione medio\n"
+ " dell'impianto che produce elettricità</td>\n"
+ " <?=$results['RendimentoElettrico']?>\n"
+ " <td> </td>\n"
+ " </tr>\n"
+ " <tr class=\"cogenerazione\">\n"
+ " <?=$results['RendElCostr']?>\n"
+ " <td>specificare se: dichiarato dal costruttore o dato medio ricavato\n"
+ " in esercizio</td>\n"
+ " </tr>\n\n"
+ " <tr>\n"
+ " <td class=\"capolinea\">B6.</td>\n"
+ " <td class=\"grassetto\">Sigla generatore</td>\n"
+ " <?=$results['SiglaGeneratore']?>\n"
+ " <td class=\"corsivo\">La sigla del generatore riportata\n"
+ " nell'autorizzazione alle emissioni in atmosfera (rilasciata dalla\n"
+ " Provincia ai sensi del DPR n. 203 del 1988 o del D.Lgs. n. 152 del\n"
+ " 2006), <b>se l'impianto prevede il rilascio di tale autorizzazione</b></td>\n"
+ " </tr>\n\n"
+ " <tr>\n"
+ " <td class=\"capolinea\">B7.</td>\n"
+ " <td class=\"grassetto\">Ore di funzionamento annue</td>\n"
+ " <?=$results['OreAnnue']?>\n"
+ " <td> </td>\n"
+ " </tr>\n\n"
+ " <tr class=\"piccolo medio\">\n"
+ " <td class=\"capolinea\">B8.</td>\n"
+ " <td class=\"grassetto\">Inquinante; emissioni; unità di misura</td>\n"
+ " <?=$results['Inqinanti']?>\n"
+ " <td class=\"corsivo\"><b>ogni impianto soggetto ad autorizzazione alle\n"
+ " emissioni</b> deve fare o un autonomo controllo 1 volta l'anno (si\n"
+ " tratta di certificati analitici: si prega di inviare tali relazioni\n"
+ " in allegato alla presente tabella) o misure in continuo (in questo\n"
+ " caso indicare l'inquinante, le emissioni corrispondenti e l'unità di\n"
+ " misura).</td>\n"
+ " </tr>\n\n"
+ " <tr class=\"piccolo medio\">\n"
+ " <td class=\"capolinea\">B9.</td>\n"
+ " <td class=\"grassetto\">Sistema di abbattimento degli inquinanti</td>\n"
+ " <?=$results['Abbattimento']?>\n\n"
+ " <td class=\"corsivo\">Indicare i sistemi di abbattimento degli\n"
+ " inquinanti installati, eventualmente unendo più celle se più\n"
+ " generatori fanno riferimento ad un unico camino e ad un'unica linea\n"
+ " fumi</td>\n"
+ " </tr>\n"
+ " </table>\n"
+ " <?=$results['bottoni']?>\n"
+ " </form>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}