#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^\w+(?=\s+OBJECT-TYPE)"
Local $sString = "STEELHEAD-MIB DEFINITIONS ::= BEGIN" & @CRLF & _
"" & @CRLF & _
"IMPORTS" & @CRLF & _
" OBJECT-TYPE, MODULE-IDENTITY, NOTIFICATION-TYPE, Unsigned32," & @CRLF & _
" TimeTicks, IpAddress, Counter32, Counter64 FROM SNMPv2-SMI" & @CRLF & _
" DateAndTime FROM SNMPv2-TC" & @CRLF & _
" products FROM RBT-MIB;" & @CRLF & _
"" & @CRLF & _
"steelhead MODULE-IDENTITY" & @CRLF & _
" LAST-UPDATED "201401070000Z"" & @CRLF & _
" ORGANIZATION "Riverbed Technology, Inc."" & @CRLF & _
" CONTACT-INFO" & @CRLF & _
" " Riverbed Technical Support" & @CRLF & _
" support@riverbed.com"" & @CRLF & _
" DESCRIPTION "Steelhead MIB"" & @CRLF & _
" REVISION "201401070000Z"" & @CRLF & _
" DESCRIPTION "Connection forwarding cluster incompatible trap"" & @CRLF & _
" REVISION "201301250000Z"" & @CRLF & _
" DESCRIPTION "Corrections in descriptions of some traps"" & @CRLF & _
" REVISION "201210170000Z"" & @CRLF & _
" DESCRIPTION "Added trap for CF Peer IPv6 incompatible alarm"" & @CRLF & _
" REVISION "201202030000Z"" & @CRLF & _
" DESCRIPTION "Updated for 7.0.1"" & @CRLF & _
" ::= { products 1 }" & @CRLF & _
"" & @CRLF & _
"system OBJECT IDENTIFIER" & @CRLF & _
" ::= { steelhead 1 }" & @CRLF & _
"" & @CRLF & _
"status OBJECT IDENTIFIER" & @CRLF & _
" ::= { steelhead 2 }" & @CRLF & _
"" & @CRLF & _
"config OBJECT IDENTIFIER" & @CRLF & _
" ::= { steelhead 3 }" & @CRLF & _
"" & @CRLF & _
"alarms OBJECT IDENTIFIER" & @CRLF & _
" ::= { steelhead 4 }" & @CRLF & _
"" & @CRLF & _
"statistics OBJECT IDENTIFIER" & @CRLF & _
" ::= { steelhead 5 }" & @CRLF & _
"" & @CRLF & _
"--" & @CRLF & _
"--" & @CRLF & _
"-- SYSTEM" & @CRLF & _
"--" & @CRLF & _
"--" & @CRLF & _
"" & @CRLF & _
"model OBJECT-TYPE" & @CRLF & _
" SYNTAX OCTET STRING" & @CRLF & _
" MAX-ACCESS read-only" & @CRLF & _
" STATUS current" & @CRLF & _
" DESCRIPTION" & @CRLF & _
" "Appliance model"" & @CRLF & _
" ::= { system 1 }" & @CRLF & _
"" & @CRLF & _
"serialNumber OBJECT-TYPE" & @CRLF & _
" SYNTAX OCTET STRING" & @CRLF & _
" MAX-ACCESS read-only" & @CRLF & _
" STATUS current" & @CRLF & _
" DESCRIPTION" & @CRLF & _
" "Appliance serial number"" & @CRLF & _
" ::= { system 2 }" & @CRLF & _
"" & @CRLF & _
"systemVersion OBJECT-TYPE" & @CRLF & _
" SYNTAX OCTET STRING" & @CRLF & _
" MAX-ACCESS read-only" & @CRLF & _
" STATUS current" & @CRLF & _
" DESCRIPTION" & @CRLF & _
" "System software version string"" & @CRLF & _
" ::= { system 3 }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"--" & @CRLF & _
"--" & @CRLF & _
"-- STATUS" & @CRLF & _
"--" & @CRLF & _
"--" & @CRLF & _
"" & @CRLF & _
"systemClock OBJECT-TYPE" & @CRLF & _
" SYNTAX DateAndTime" & @CRLF & _
" MAX-ACCESS read-only" & @CRLF & _
" STATUS current" & @CRLF & _
" DESCRIPTION" & @CRLF & _
" "System clock time"" & @CRLF & _
" ::= { status 1 }" & @CRLF & _
"" & @CRLF & _
"health OBJECT-TYPE" & @CRLF & _
" SYNTAX OCTET STRING" & @CRLF & _
" MAX-ACCESS read-only" & @CRLF & _
" STATUS current" & @CRLF & _
" DESCRIPTION" & @CRLF & _
" "Current health of the system. The value is one amongst" & @CRLF & _
" Healthy, Admission Control, Degraded, Critical"" & @CRLF & _
" ::= { status 2 }" & @CRLF & _
"" & @CRLF & _
"serviceStatus OBJECT-TYPE" & @CRLF & _
" SYNTAX OCTET STRING" & @CRLF & _
" MAX-ACCESS read-only" & @CRLF & _
" STATUS current" & @CRLF & _
" DESCRIPTION" & @CRLF & _
" "Current status of the optimization service"" & @CRLF & _
" ::= { status 3 }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")