$re = '/([A-Z][a-z]*(?:\s?[A-Z][a-z]+)*|[a-z]+)/';
$str = 'The city of San Francisco is truly beautiful!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);