package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`co(lo)?r`)
var str = `color colour cor`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}