const regex = /^sub-(?!A00018030|A00066396)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^sub-(?!A00018030|A00066396)(.*)$', 'gm')
const str = `sub-A00018030
sub-A00065990
sub-A00066389
sub-A00066800
sub-A00073529
sub-A00019903
sub-A00065992
sub-A00066396
sub-A00066812
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}