re = /(?<=^|\s)([^:]+):(\S*)(?=$|\s)/m
str = 'id:pgl01130529155035239084 sub:001 dlvrd:001 submit date:1305291550 done date:1305291550 stat:DELIVRD err:0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end