$re = '/^(?:[0-9][- ])?\(?[0-9]{3}\)?[- ][0-9]{3}[- ][0-9]{4}$/m';
$str = '(555) 555-5555
(444) 444 4444
333-333-3333
1-222-222-2222
1 (888) 888-8888
1 (777) 777-7777';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);