#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*?)(\.|_?)(000\d{0,})(.*)\.jpg"
Local $sString = "test_canon_shot02.jpg " & @CRLF & _
"test_shot01-04.jpg " & @CRLF & _
"test_shot02-03.jpg " & @CRLF & _
"test_shot02-02.jpg " & @CRLF & _
"test_shot01-03.jpg " & @CRLF & _
"test_canon_shot03.jpg " & @CRLF & _
"test_shot01-02.jpg " & @CRLF & _
"test_shot02.jpg" & @CRLF & _
"test_canon_shot02.jpg" & @CRLF & _
"test_shot01.jpg " & @CRLF & _
"GameAssets_.00024.jpg " & @CRLF & _
"GameAssets_.00023.jpg " & @CRLF & _
"GameAssets_.00022.jpg " & @CRLF & _
"GameAssets_.00021.jpg " & @CRLF & _
"GameAssets_.00020.jpg " & @CRLF & _
"GameAssets_.00019.jpg " & @CRLF & _
"GameAssets_.00018.jpg " & @CRLF & _
"GameAssets_.00017.jpg " & @CRLF & _
"GameAssets_.00016.jpg " & @CRLF & _
"GameAssets_.00015.jpg " & @CRLF & _
"GameAssets_.00014.jpg " & @CRLF & _
"GameAssets_.00013.jpg " & @CRLF & _
"GameAssets_.00012.jpg " & @CRLF & _
"GameAssets_.00011.jpg " & @CRLF & _
"GameAssets_.00010.jpg " & @CRLF & _
"GameAssets_.00009.jpg " & @CRLF & _
"GameAssets_.00008.jpg " & @CRLF & _
"GameAssets_.00007.jpg " & @CRLF & _
"GameAssets_.00006.jpg " & @CRLF & _
"GameAssets_.00005.jpg " & @CRLF & _
"GameAssets_.00004.jpg " & @CRLF & _
"GameAssets_.00003.jpg " & @CRLF & _
"GameAssets_.00002.jpg " & @CRLF & _
"GameAssets_.00001.jpg " & @CRLF & _
"GameAssets_.00000.jpg " & @CRLF & _
"OrangeXmas2015_Print_A ct2.jpg " & @CRLF & _
"sh120_HF_V01-01.jpg " & @CRLF & _
"sh120_HF_V01-02.jpg " & @CRLF & _
"sh200_DMP_v04.jpg " & @CRLF & _
"sh120_HF_V04.jpg " & @CRLF & _
"sh120_HF_V03.jpg " & @CRLF & _
"sh120_HF_V02.jpg " & @CRLF & _
"blah_v02.jpg " & @CRLF & _
"blah_v01.jpg " & @CRLF & _
"blah_Capture0 4.jpg " & @CRLF & _
"blah_Capture03 .jpg " & @CRLF & _
"blah_Capture01. jpg " & @CRLF & _
"blah_Capture02.jpg " & @CRLF & _
"Wall_GraniteBlock_G rey_TC041813.jpg" & @CRLF & _
"Renders10_wire.jpg " & @CRLF & _
"Renders10.jpg " & @CRLF & _
"Renders09_wire.jpg " & @CRLF & _
"Renders09.jpg " & @CRLF & _
"Renders08_wire.jpg " & @CRLF & _
"Renders08.jpg " & @CRLF & _
"Renders07_wire.jpg " & @CRLF & _
"Renders07.jpg " & @CRLF & _
"Renders06_wire.jpg " & @CRLF & _
"Renders06.jpg " & @CRLF & _
"Renders05_wire.jpg " & @CRLF & _
"Renders05.jpg " & @CRLF & _
"Renders04_wire.jpg " & @CRLF & _
"Renders04.jpg " & @CRLF & _
"Renders03_wire.jpg " & @CRLF & _
"Renders03.jpg " & @CRLF & _
"Renders02_wire.jpg " & @CRLF & _
"Renders02.jpg " & @CRLF & _
"Renders01_wire.jpg " & @CRLF & _
"Renders01.jpg " & @CRLF & _
"archmodels58_057_carpinusbetulus_leaf_diffuse.jpg " & @CRLF & _
"archmodels58_042_bark_bump.jpg " & @CRLF & _
"archmodels58_023_leaf_diffuse.jpg " & @CRLF & _
"WINDY TECHNICZNE-reflect00.jpg " & @CRLF & _
"archmodels58_057_leaf_opacity.jpg " & @CRLF & _
"archmodels58_057_bark_reflect.jpg " & @CRLF & _
"archmodels58_057_bark_bump.jpg " & @CRLF & _
"blahC-00-oknaka.jpg " & @CRLF & _
"bed " & @CRLF & _
"debt " & @CRLF & _
"cab " & @CRLF & _
"00018.jpg " & @CRLF & _
"00017.jpg " & @CRLF & _
"00016.jpg " & @CRLF & _
"00015.jpg " & @CRLF & _
"00014.jpg " & @CRLF & _
"00013.jpg " & @CRLF & _
"00012.jpg " & @CRLF & _
"00011.jpg " & @CRLF & _
"00010.jpg " & @CRLF & _
"00009.jpg " & @CRLF & _
"00008.jpg " & @CRLF & _
"00007.jpg " & @CRLF & _
"00006.jpg " & @CRLF & _
"00005.jpg " & @CRLF & _
"00004.jpg " & @CRLF & _
"00003.jpg " & @CRLF & _
"00002.jpg " & @CRLF & _
"00001.jpg " & @CRLF & _
"00000.jpg "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")