using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([^<>()\[\]\.,;:\s@\""]+(\.[^<>()\[\]\.,;:\s@\""]+)*)|(\"".+\""))@(([^<>()[\]\.,;:\s@\""]+\.)+[^<>()[\]\.,;:\s@\""]{2,})";
string substitution = @"QuestionText = ""$1"",";
string input = @"prettyandsimple@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-dash@example.com
x@example.com (one-letter local part)
""much.more unusual""@example.com
""very.unusual.@.unusual.com""@example.com
""very.(),:;<>[]\"".VERY.\""very@\\ \""very\"".unusual""@strange.example.com
example-indeed@strange-example.com
admin@mailserver1 (local domain name with no TLD)
#!$%&'*+-/=?^_`{}|~@example.org
""()<>[]:,;@\\\""!#$%&'*+-/=?^_`{}| ~.a""@example.org
"" ""@example.org (space between the quotes)
example@localhost (sent from localhost)
example@s.solutions (see the List of Internet top-level domains)
user@com
user@localserver
user@[IPv6:2001:db8::1]
©other.email-with-dash@example.com
?prettyandsimple@example.com
Invalid email addresses[edit]
Abc.example.com (no @ character)
A@b@c@example.com (only one @ is allowed outside quotation marks)
a""b(c)d,e:f;g<h>i[j\k]l@example.com (none of the special characters in this local part are allowed outside quotation marks)
just""not""right@example.com (quoted strings must be dot separated or the only element making up the local part)
this is""not\allowed@example.com (spaces, quotes, and backslashes may only exist when within quoted strings and preceded by a backslash)
this\ still\""not\\allowed@example.com (even if escaped (preceded by a backslash), spaces, quotes, and backslashes must still be contained by quotes)
john..doe@example.com (double dot before @)
with caveat: Gmail lets this through, Email address#Local-part the dots altogether
john.doe@example..com (double dot after @)";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}